[FieldTrip] Having troubles with Emotiv + Fieldtrip + Matlab

Lilla.Magyari at mpi.nl Lilla.Magyari at mpi.nl
Thu Sep 6 14:45:55 CEST 2012

Hello Ricardo,

I haven't tried to work with Emotiv, but I see an FtBuffer.h file in the
latest version of FieldTrip in the  realtime/src/buffer/cpp. I hope this

(It is also not clear for me if you downloaded only files related to
emotive, or also the whole FieldTrip package (this latest is probably


> Hello there,
> I'm new to Fieldtrip: I've been assigned to work with signals acquired
> by Emotiv in Matlab environment, specially in real-time - or at least
> almost real-time - so I can work and study these signals with my own
> Matlab's functions. However, here's the bad thing: we did not expect
> it to be that complicated to extract signals directly to Matlab.
> While searching for any module, program, anything I could find, to
> help our problem, I found Fieldtrip. Correct me if I am wrong, but it
> seems that it is able to stream/buffer from emotiv's sdk to matlab.
> The problem is that we do not have that much experience with compiling
> C programs, hence I am having a really hard time to understand what do
> you mean with:
> "Compilation
> We provide a simple Makefile for the MinGW compiler, but you will need
> the Emotiv SDK. Please go to the realtime/datasource/emotiv directory
> and type make or mingw32-make. Note that you might need to compile the
> libbuffer library first."
> Here's what I did so far:
> 1. I have installed Matlab r2011b 64-bit and Emotiv SDK Research Edition;
> 2. I installed MinGW and set the path of the /bin in environmental
> variables;
> 3. I downloaded all these files from:
> http://code.google.com/p/fieldtrip/source/browse/trunk/realtime/datasource/emotiv/?r=1742
> 4. Then I went cmd and tried to do: mingw32-make -f makefile.gcc
> which obviously failed: it said it was missing a file "Ftbuffer.h". I
> assumed it was the libbuffer library, however I can't seem to find it
> anywhere in the Internet (just some site that would ask me to install
> Makestuff application, which I did and was unsuccessful.
> I found a "buffer" folder in fieldtrip release but I dont think it's that.
> Hence I tried to download the Ftbuffer.h itself from internet and put
> it in the folder where emotiv2ft was. It worked, but then it started
> to ask others files.... and more.. and more..
> So, obviously I'm stuck right here.
> Can you help me right here? What should I do? Have I done something wrong?
> I've read this discussion list and found one thread quite related to
> this - but his problem was not having research edition, which in fact,
> I do have it.
> I'm sorry bothering you with probably authentic beginner questions,
> but as I said, I only have high experience with Matlab.
> Best Regards,
> Ricardo
> _______________________________________________
> fieldtrip mailing list
> fieldtrip at donders.ru.nl
> http://mailman.science.ru.nl/mailman/listinfo/fieldtrip

More information about the fieldtrip mailing list