[FieldTrip] Having troubles with Emotiv + Fieldtrip + Matlab

Robert Oostenveld r.oostenveld at donders.ru.nl
Thu Sep 6 15:05:32 CEST 2012

Dear Ricardo,

We provide the full source code for you to investigate, modify and recompile, but we also provide pre-compiled binaries that you shoiuld be able to use to just get it to run. Rather than just grabbing a small section of the fieldtrip code, which you seem to have done, I suggest you get a complete fieldtrip version from http://fieldtrip.fcdonders.nl/download or through SVN (you want the complete trunk).

In the fieldtrip/realtime/bin/win32 directory you will find the compiled emotiv2ft.exe program (it is present both in th ezip file from the ftp, as well as in the svn version). The emotiv2ft.exe application copies the data from the emotiv dll into the FT buffer, where you can access it from MATLAB using the methods described here http://fieldtrip.fcdonders.nl/getting_started/realtime for end-users and here http://fieldtrip.fcdonders.nl/development/realtime for developers.

Hope this helps,

On 6 Sep 2012, at 12:25, Ricardo Jorge wrote:

> Hello there,
> I'm new to Fieldtrip: I've been assigned to work with signals acquired
> by Emotiv in Matlab environment, specially in real-time - or at least
> almost real-time - so I can work and study these signals with my own
> Matlab's functions. However, here's the bad thing: we did not expect
> it to be that complicated to extract signals directly to Matlab.
> While searching for any module, program, anything I could find, to
> help our problem, I found Fieldtrip. Correct me if I am wrong, but it
> seems that it is able to stream/buffer from emotiv's sdk to matlab.
> The problem is that we do not have that much experience with compiling
> C programs, hence I am having a really hard time to understand what do
> you mean with:
> "Compilation
> We provide a simple Makefile for the MinGW compiler, but you will need
> the Emotiv SDK. Please go to the realtime/datasource/emotiv directory
> and type make or mingw32-make. Note that you might need to compile the
> libbuffer library first."
> Here's what I did so far:
> 1. I have installed Matlab r2011b 64-bit and Emotiv SDK Research Edition;
> 2. I installed MinGW and set the path of the /bin in environmental variables;
> 3. I downloaded all these files from:
> http://code.google.com/p/fieldtrip/source/browse/trunk/realtime/datasource/emotiv/?r=1742
> 4. Then I went cmd and tried to do: mingw32-make -f makefile.gcc
> which obviously failed: it said it was missing a file "Ftbuffer.h". I
> assumed it was the libbuffer library, however I can't seem to find it
> anywhere in the Internet (just some site that would ask me to install
> Makestuff application, which I did and was unsuccessful.
> I found a "buffer" folder in fieldtrip release but I dont think it's that.
> Hence I tried to download the Ftbuffer.h itself from internet and put
> it in the folder where emotiv2ft was. It worked, but then it started
> to ask others files.... and more.. and more..
> So, obviously I'm stuck right here.
> Can you help me right here? What should I do? Have I done something wrong?
> I've read this discussion list and found one thread quite related to
> this - but his problem was not having research edition, which in fact,
> I do have it.
> I'm sorry bothering you with probably authentic beginner questions,
> but as I said, I only have high experience with Matlab.
> Best Regards,
> Ricardo
> _______________________________________________
> fieldtrip mailing list
> fieldtrip at donders.ru.nl
> http://mailman.science.ru.nl/mailman/listinfo/fieldtrip

More information about the fieldtrip mailing list