[FieldTrip] MEX file error

Sendy Caffarra s.caffarra at bcbl.eu
Tue Feb 4 19:55:37 CET 2020

Hi all,

I'm trying to use the latest version of Fieldtrip on Matlab R2019b (and MacOS Catalina 10.15.3) but it gives me this error:

>> cfg            = [];
cfg.dataset    = 'test.edf';
cfg.continuous = 'yes';
cfg.channel    = 'all';
data           = ft_preprocessing(cfg);

Invalid MEX-file '/Users/caffarra/Documents/toolbox/fieldtrip-20200130/utilities/ft_getopt.mexmaci64':
dlopen(/Users/caffarra/Documents/toolbox/fieldtrip-20200130/utilities/ft_getopt.mexmaci64, 6): no suitable image
found.  Did find:
        /Users/caffarra/Documents/toolbox/fieldtrip-20200130/utilities/ft_getopt.mexmaci64: code signature in
        (/Users/caffarra/Documents/toolbox/fieldtrip-20200130/utilities/ft_getopt.mexmaci64) not valid for use in
        process using Library Validation: library load disallowed by system policy

I've tried to recompile all MEX files using either ft_compile_mex or from terminal (as suggested here http://www.fieldtriptoolbox.org/faq/matlab_complains_about_a_missing_or_invalid_mex_file_what_should_i_do/) but I get the same error.

Any suggestion is more than welcome.

Sendy Caffarra

More information about the fieldtrip mailing list