[FieldTrip] Trouble writing data from TMSi to FieldTrip buffer (Error message: "Cannot initiate device")

Jostein Holmgren holmgren.jostein at gmail.com
Tue Nov 28 21:29:07 CET 2017

Dear all,

I am having trouble writing data from my TMSi Porti 7 system to the FieldTrip buffer. I have tried both the tmsidriver.exe and tmsi2ft.exe tools, but I’ve focused my efforts on the latter.

I have the TMSi system connected to my PC via USB and have tested the connection by recording some data in Polybench without issue. When I attempt to run tmsi2ft nothing happens until I terminate the process, at which point the error message “Cannot initiate device” is displayed. The exact syntax I run in the cmd is

	tmsi2ft config.txt -

where config.txt file contains the following (misc commented lines excluded)


For testing purposes I’ve only got a bipolar electrode connected to the TMSi system, which is the channel listed in the config file.

For tmsidriver.exe I changed the sampling rate in parameter file to match my system to attempt to get it to work, but no success there either. I also have the buffer open when running tmsidriver.exe. The contents of preferences.txt is

	sampleRate(milliHz)	BufSizeFactor		savedata(0/1)
	2048000				5				1

The TMSi Porti 7 system has a sampling rate of 2048Hz. The PC is running Windows 8.1 64-bit. I’m using fieldtrip-20171106.

Any advice or suggestions is greatly appreciated.

Best regards,
Jostein Holmgren


Jostein Holmgren
DPhil Student (PRS)
Nuffield Department of Clinical Neurosciences
Wellcome Centre for Integrative Neuroimaging, FMRIB Building
University of Oxford

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.science.ru.nl/pipermail/fieldtrip/attachments/20171128/866d67da/attachment-0001.html>

More information about the fieldtrip mailing list