[FieldTrip] Fwd: [HCP-Users] hcp_anatomy.m needs an hsfile?

Schoffelen, J.M. (Jan Mathijs) jan.schoffelen at donders.ru.nl
Mon Mar 13 09:13:50 CET 2017

Dear Jeff,

Let me forward your question to the discussion list.

Dear list,

Jeff is encountering some coregistration problems, which may be FieldTrip related, but also could be a user error. Perhaps somebody has encountered them before. Let us know if you have a solution.

The 45 degrees tilt looks odd. If this image was produced after reslicing the to-MNI-coregistered-image something went wrong with the realignment. If this image was produced prior to the reslicing, something funky has gone wrong with the acquisition sequence.

I don’t know anything about the specifics of Brainstorm, so I am afraid I cannot help there.



J.M.Schoffelen, MD PhD
Senior Researcher, VIDI-fellow - PI, language in interaction
Telephone: +31-24-3614793
Physical location: room 00.028
Donders Centre for Cognitive Neuroimaging, Nijmegen, The Netherlands

Begin forwarded message:

From: K Jeffrey Eriksen <eriksenj at ohsu.edu<mailto:eriksenj at ohsu.edu>>
Subject: RE: [HCP-Users] hcp_anatomy.m needs an hsfile?
Date: 11 March 2017 at 02:47:33 GMT+1
To: "Schoffelen, J.M. (Jan Mathijs)" <jan.schoffelen at donders.ru.nl<mailto:jan.schoffelen at donders.ru.nl>>

Hello again,

I encountered a problem when I tried to import into Brainstorm, even though I thought I had the transform text file correct. After importing the anatomy in Brainstorm, it was displayed with the brain rotated by 45 degrees in all axes. I then realized the I had visualized the registration of the headshape to the scalp surface and that looked good, but I had never visualized the MNI registration.

I went back into the HCP scripts and found where the MNI registration could be visualized and discovered the 45 degree rotation seemed to occur there. So I thought maybe our local HCP pipeline did something unusual. To test this I ran these three conditions:

1.       My hcp_anatomy_egi.m with our local HCP-pipeline produced T1
2.       original hcp_anatomy.m with our local T1
3.       original hcp_anatomy.m with downloaded HCM_MEG_pipeline produced T1

All three had the same apparent problem, shown on the attached images. I am quite puzzled by this since they are all the same, yet Brainstorm only imports #3 correctly (not counting #2 which is mixed).

I put all three cases in the attached Word doc, with the Brainstorm registration display and the HCP headshape registration display.


From: Schoffelen, J.M. (Jan Mathijs) [mailto:jan.schoffelen at donders.ru.nl]
Sent: Wednesday, March 08, 2017 8:52 AM
To: K Jeffrey Eriksen
Subject: Re: [HCP-Users] hcp_anatomy.m needs an hsfile?

Hi Jeff,

I made it all the way through hcp_anatomy_EGI.m (my version substituting ‘egi’ for ‘bti’. Amazing!

I could not figure out how to do the interactive fine registration of the EGI electrode “headshape” to the scalp surface – where is that documented?

Well it’s not extensively documented, but in the crude GUI you can fiddle around with translation and rotation parameters to move the electrode point cloud closer to the headsurface  mesh, created from the MRI segmentation.

The main remaining problem is that the BTI coordinate system has the X-axis toward the nasion, and the Y-axis toward the LPA. The EGI coordinate system has the X-axis toward the RPA and the Y-axis toward the nasion. Can you suggest the best way to change hcp_anatomy_EGI.m to reflect this?

Well, it sounds as if the EGI has an RAS convention, which may be similar to the ‘neuromag’ convention (as per http://www.fieldtriptoolbox.org/faq/how_are_the_different_head_and_mri_coordinate_systems_defined)

It could be that changing the required coordinate system (coordsys) to ‘neuromag’ while specifying the fiducials in ft_volumerealign (rather than ‘bti’) would do the trick.

Each of the supported coordinates systems must have some kind of master definition somewhere in the code, and that would be the best place to define the EGI system. I think it is similar to the BESA system.

The code that has the ‘intelligence’ to map the specification of defined fiducial/landmark locations is in https://github.com/fieldtrip/fieldtrip/blob/master/utilities/ft_headcoordinates.m
with a typo in line48/49 I noticed just now.

Feel free to suggest a new coordinate system if needed. Perhaps this is best done through the fieldtrip discussion list.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.science.ru.nl/pipermail/fieldtrip/attachments/20170313/870dea0e/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 45 degree rotqation of MNI registration HCP_MEG_anatomy.docx
Type: application/vnd.openxmlformats-officedocument.wordprocessingml.document
Size: 494751 bytes
Desc: 45 degree rotqation of MNI registration HCP_MEG_anatomy.docx
URL: <http://mailman.science.ru.nl/pipermail/fieldtrip/attachments/20170313/870dea0e/attachment-0001.docx>

More information about the fieldtrip mailing list