[FieldTrip] running FT scripts in a supercomputing cluster

Schoffelen, J.M. (Jan Mathijs) jan.schoffelen at donders.ru.nl
Fri Jun 10 11:11:30 CEST 2016

Hi Jose,

Have you tried to explicitly add all required (sub)directories with the -a option?

Something like mcc …. -a $FTDIR/fileio -a $FTDIR/… -a $FTDIR/etc

It’s been a while that I have tried to compile some stuff myself, but I remember that back then I remember that I needed to instruct mcc with a list of directories explicitly

Best, Jan-Mathijs

> On 10 Jun 2016, at 10:42, Jose <joseluisblues at gmail.com> wrote:
> dear list,
> I'm trying to analyse CTF MEG data through the Flemish Supercomputer Centre,
> I did a matlab script to run the foremost FT functions in my pipeline (ft_read_event, read_ctf_cls, and ft_preprocessing). This script works well when I run it locally. To compile my function in the supercomputing cluster I initially used addpath to include FT and ft_defaults to set the configuration inside my script, but this wasn't working. I tried using a startup.m script but this doesn't work neither. Maybe I'm missing something? My bash script to compile looks like this:
> #!/bin/bash
> module load MATLAB/2013b
> FTDIR=$VSC_DATA_VO_USER/fieldtrip-20160317
> mcc -mv FT_0.m
> I also tried mcc -mv FT_0.m -I $FTDIR
> I run my compilation in the same folder where I have the FT folder.
> When I run my bash job I get always the same error: Undefined function 'ft_read_event' for input arguments of type 'char'.
> I've been looking elsewhere but still I haven't find a solution,
> Any hints about this would really appreciated,
> best,
> Jose
> _______________________________________________
> fieldtrip mailing list
> fieldtrip at donders.ru.nl
> http://mailman.science.ru.nl/mailman/listinfo/fieldtrip

More information about the fieldtrip mailing list