[FieldTrip] running FT scripts in a supercomputing cluster

Jose joseluisblues at gmail.com
Fri Jun 10 10:42:39 CEST 2016

dear list,

I'm trying to analyse CTF MEG data through the Flemish Supercomputer Centre,
I did a matlab script to run the foremost FT functions in my pipeline
(ft_read_event, read_ctf_cls, and ft_preprocessing). This script works well
when I run it locally. To compile my function in the supercomputing cluster
I initially used addpath to include FT and ft_defaults to set the
configuration inside my script, but this wasn't working. I tried using a
startup.m script but this doesn't work neither. Maybe I'm missing
something? My bash script to compile looks like this:

module load MATLAB/2013b
mcc -mv FT_0.m

I also tried mcc -mv FT_0.m -I $FTDIR
I run my compilation in the same folder where I have the FT folder.
When I run my bash job I get always the same error: Undefined function
'ft_read_event' for input arguments of type 'char'.

I've been looking elsewhere but still I haven't find a solution,

Any hints about this would really appreciated,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.science.ru.nl/pipermail/fieldtrip/attachments/20160610/4021317e/attachment-0001.html>

More information about the fieldtrip mailing list