[FieldTrip] Why does ft_selectdata remove "pow" from sourcedata during statistics?

Andreas Sauer sauer.mpih at googlemail.com
Sun Apr 24 18:36:06 CEST 2016

Dear all,

unfortunately, I am having problems to run source statistics on ERF
mismatch negativity data (recorded with a 4D system).

With the following data structure as input (output from
ft_sourcegrandaverage), fieldtrip gives a warning that it „could not
determine dimord of „pow“ in the following data“

pow: [16x37696 double]

dim: [31 38 32]

inside: [37696x1 logical]

pos: [37696x3 double]

time: [1x900 double]

cfg: [1x1 struct]

and later throws an error that „field „pow“ (is) not present in data“. I
checked the ft_sourcestatistic script step by step and found out that
ft_selectdata removes it after being called by ft_sourcestatistics.

I am using the fieldtrip version from 15/05/2015. I also tried with older
versions, one from late 2014 and late 2013, but nothing worked.

Unfortunately, since ft_selectdata removes the field "pow" from the data
during the call to ft_sourcestatistic, I can’t put it back in to the

Any help with this (esp. why „pow“ is being removed) is highly appreciated!

Thanks and best wishes,


Dipl.-Psych. Andreas Sauer
Max Planck Institute for Brain Research
Deutschordenstraße 46
60528 Frankfurt am Main

T: +49 69 96769 278
F: +49 69 96769 327
Email: sauer.mpih at gmail.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.science.ru.nl/pipermail/fieldtrip/attachments/20160424/f3fe51fd/attachment-0001.html>

More information about the fieldtrip mailing list