[FieldTrip] error when running ft_timelockanalysis

s.rombetto at cib.na.cnr.it s.rombetto at cib.na.cnr.it
Thu Jun 12 10:29:34 CEST 2014

Hi Tyler

this problem has already been solved by Jörn M. Horschig.
I attach here the answer he gave to me some time ago

Best regards

----- Messaggio inoltrato da jm.horschig at donders.ru.nl -----
     Data: Wed, 14 May 2014 10:35:03 +0200
       Da: "Jörn M. Horschig" <jm.horschig at donders.ru.nl>
Rispondi-A:FieldTrip discussion list <fieldtrip at science.ru.nl>
  Oggetto: ***SPAM*** Re: [FieldTrip] problem occurs when using  
        A: FieldTrip discussion list <fieldtrip at science.ru.nl>

Hi Sara,

I guess you are not using a mac. What you describe concerns bug 2452 on
our Bugzilla page:
which pertains to some undocumented change in Matlab. Therefore it is
necessary to use a different mxserialize function that from matlab 2014a
onwards  than before. This is a c++ function, which requires to be
compiled for each platform independently. In FieldTrip, this file exists
e.g. in fileio/private but only for MacOS 64-bit platforms. Apparently,
we still need to compile it for MacOS 32bit, Windows and Linux
platforms. I guess we should do that quite soon ;) I'll bring it up in
today's FT meeting so that hopefully from tomorrow onwards it should work.

btw, for you it will help to go to the FieldTrip/src directory in Matlab
and type
  >> mex mxSerialize_cpp.cpp

Then Matlab will mex (~compile) the file for you. You can then copy that
file to your matlab code directory and everything should work out fine
for you. I'll keep you updated on this.


On 5/13/2014 4:15 PM, s.rombetto at cib.na.cnr.it wrote:
> Any suggestion concerning this problem?
> it works finewith Matlab 2013
> Hello fieldtrippers,
> I got the following error when trying to run ft_timelockanalysis.
> Undefined function 'mxSerialize_cpp' for input arguments of type 'struct'.
> Error in mxSerialize (line 35)
>   argout = mxSerialize_cpp(argin);
> Error in ft_preamble_provenance (line 74)
>     cfg.callinfo.inputhash{iargin} = CalcMD5(mxSerialize(tmparg));
> Error in ft_preamble (line 54)
>   evalin('caller', ['ft_preamble_' cmd]);
> Error in ft_timelockanalysis (line 95)
> ft_preamble provenance data
> I have no idea what the problem is, I tried looking for the function  
>  in my fieldtrip folder.
> I have just recently installed matlab 2014a if that is any help.
> Tyler
> *************************
> Tyler Grummett ( BBSc, BSc(Hons I))
> PhD Candidate
> Brain Signals Laboratory
> Flinders University
> Rm 5A301
> Ext 66124

  Dott.ssa Sara Rombetto
  Istituto di Cibernetica
  "E. Caianiello"
  Via Campi Flegrei, 34
  80078 Pozzuoli (NA)
  mob +39 3401689815
  tel +39 0818675361
  fax +39 0818675128
  Lab MEG 0817483511
"I disapprove of what you say, but I will defend to the death your  
right to say
it." [Evelyn Beatrice Hall, The Friends Of Voltaire]

This message was sent using IMP, the Internet Messaging Program.

More information about the fieldtrip mailing list