[FieldTrip] cannot combine planar grads with ft_combineplaner

Demarchi, Gianpaolo gianpaolo.demarchi at unitn.it
Fri Jan 3 15:09:00 CET 2014

Hi Mads,
you’re not alone!
In fact I was going to open a bug on that these days, since I’m getting similar (non) results.

With a previous ft version (6499, so more than one year old), everything seems to work fine, i.e. I get (for a Vectorview 306 channel input)
as a ft_combineplanar output:

avgdatacmbOLD =

          time: [1x1537 double]
         label: {204x1 cell}
          grad: [1x1 struct]
           cfg: [1x1 struct]
       fsample: 256
    sampleinfo: [1 1537]
           avg: [204x1537 double]
        dimord: 'chan_time'

so, correctly combined, whereas if I do the same with a recent (svn-ed) version, with the same input, I get:

avgdatacmb =

          time: [1x1537 double]
         label: {306x1 cell}
          grad: [1x1 struct]
           cfg: [1x1 struct]
       fsample: 256
    sampleinfo: [1 1537]
           avg: [306x1537 double]
        dimord: ‘chan_time'

so I get back my original, non combined, 306 channels …

I tried to track the problem before opening a bug, and it seems that the problem lays in my input data label, which is:

>> avgdata.label

ans =


etc …

The problem  seems to be around lines 102-ff of ft_combineplanar, since ft_senstype(data) on my data wrongly returns ‘neuromag306’ ( that are in principle ‘MEG 0113’ etc ...) instead of ‘neuromag306alt’ (  ‘MEG0113’ without spaces), and then in the following two lines sel_dH/sel_dV are empty, since there’s never a match between my data label (‘MEG0113’  …) and the output of ft_senstype/ft_senslabel (‘MEG 0113’ … with spaces).
So, there’s something wrong in the ft_senstype step, but I didn’t have time to fully track it …
@roboos: am I missing something obvious, or should I file a bug!?

My two €-cents,

Il giorno 03/gen/2014, alle ore 11:44, Mads Jensen <mje.mads at gmail.com<mailto:mje.mads at gmail.com>> ha scritto:

Hi all,

I have a problem with ft_combineplanar. It does not seem to combine the
planar gradiometors when called.

I have tried with timelocked data and epoched data, both are the same.
However, grandaveraged data (ft_timelockgrandaverage) create a structure
with combined data. Does anybody have an idea what the problem might be
or how I can find the problem?

I have Neuromag Triux data and is using the most recent Fieldtrip from
the git-repo.

best wish,
fieldtrip mailing list
fieldtrip at donders.ru.nl<mailto:fieldtrip at donders.ru.nl>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.science.ru.nl/pipermail/fieldtrip/attachments/20140103/df845421/attachment-0002.html>

More information about the fieldtrip mailing list