[FieldTrip] Problem with visualizing individual minimum source activity (ft_plot_mesh, ft_sourcemovie, ft_sourceplot)

Maximilian Bruchmann Maximilian.Bruchmann at uni-muenster.de
Thu Oct 18 15:55:53 CEST 2012

Dear FieldTrippers,

there used to be a very convenient way to get a look at individual mne source reconstructions using either ft_plot_mesh or ft_sourcemovie, but both no longer seem to work. When I follow the minimum norm estimate tutorial up to the point of visualization the code that worked fine some weeks ago now produces the following errors:

cfg.method = 'mne';
cfg.grid.leadfield = leadfield;
cfg.vol = vol;
cfg.mne.lambda = 1e11;
myMne = ft_sourceanalysis(cfg,timeLock);         

bnd.pnt = sourcespace.pnt;
bnd.tri = sourcespace.tri;
ft_plot_mesh(bnd, 'vertexcolor', m);

produces the error:
Error using ft_plot_mesh (line 191)
Unknown color

As it seems, 'vertexcolor' accepts only a single RGB triplet. In fact, none of the options of ft_plot_mesh seems to support the visualization of functional data anymore, am I right?

The other way using ft_sourcemovie used to work fine like this:

myMne.tri = sourcespace.tri;
cfg = [];
cfg.alim = [0 8e-14];
cfg.zlim = [0 4e-13];
cfg.maskparameter = 'avg.pow';

But now it produces the warning 
Warning: Values in patch Faces must be in [1 : rows(Vertices)] - not rendering 
and I get an empty figure window.

I tried ft_sourceplot:

cfg              = [];
cfg.method       = 'surface';
cfg.funparameter = 'avg.pow';

but irrespective of the method I get
Error using ft_sourceplot (line 188)
the input data needs to be defined on a regular 3D grid

Any help on how I can view my source reconstruction results as a colored source space model would be very appreciated! 
Thanks in advance!

More information about the fieldtrip mailing list