[FieldTrip] error in ft_prepare_layout

Marijke Beulen m.a.beulen at rug.nl
Thu Nov 17 12:14:00 CET 2011

Dear FieldTrip users,

I have just started using FieldTrip (the latest version), but I have run into what looks like a bug. I basically just followed the artifact removal steps from the FieldTrip for dummies document. After doing the ICA on some EEG data, I tried to look at the resulting ic_data with ft_databrowser(cfg,ic_data), but then I get the following error:
 ??? Undefined function or variable 'ftFuncTimer'.

Error in ==> ft_postamble_callinfo at 17

cfg.callinfo.proctime = toc(ftFuncTimer);

Error in ==> ft_postamble at 27

evalin('caller', ['ft_postamble_' cmd]);

Error in ==> ft_prepare_layout>sens2lay at 783

ft_postamble callinfo


Error in ==> ft_prepare_layout at 252

lay = sens2lay(cfg.elec, cfg.rotate, cfg.projection, cfg.style);


Error in ==> ft_databrowser at 162

cfg.layout = ft_prepare_layout(tmpcfg);

If I understand correctly, ft_postamble is called at the end of the function sens2lay within ft_prepare_layout and it tries to calculate the amount of time and memory used, but it has no start measurement to compare with because these variables don't exist. The only time when ft_preamble is called seems to be at the beginning of ft_prepare_layout, and the output of this is not passed on to the other functions it calls.

When someone else tried to do the same thing with an older version of FieldTrip, it worked normally. Is this a bug in the newer version, or am I doing something wrong?

Thanks in advance for your help,

Marijke Beulen

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.science.ru.nl/pipermail/fieldtrip/attachments/20111117/8097b22b/attachment-0001.html>

More information about the fieldtrip mailing list