[FieldTrip] problem with ft_read_mri

Robert Oostenveld r.oostenveld at donders.ru.nl
Sun Feb 20 21:03:12 CET 2011

Dear Yaqub (and Cristian, who recently had a similar question)

FieldTrip uses SPM for some of the MRI reading and processing. For that purpose, fieldtrip/external/spm2 and  fieldtrip/external/spm8 are included in the fieldtrip release version. These are automatically added to the path when needed, but will not be added to the path if you already have another version of spm on your path.

Your problem (not having the mex file for the right problem) should be solved if you ensure that fieldtrip/external/spm8 is on your path. That version of SPM8 includes the mex files for 64 bit MS Windows and for 64 bit Mac OS X. The ft_read_mri will then call the correct compiled mex file.

best regards,

On 18 Feb 2011, at 22:42, yacob Jon Mohamady wrote:

> Hi there,
> I want to calculate the BEM fo EEG.
> When I run this command line:
> mri = ft_read_mri('t1_icbm_normal_1mm_pn0_rf0.mnc');
> it gives the following error:
> Error using ==> spm_platform>init_platform at 173
> PCWIN64 not supported architecture for SPM
> I have SPM8 and when I change my SPM8 to SPM5 it gives this erros:
> Error using ==> fread
> Invalid size.
> I have windows 7, 64-bit and MATLAB 2010a 64-bit.
> Do you know how I can fix the problem, please.
> Thank you
> Yaqub
>  _______________________________________________
> fieldtrip mailing list
> fieldtrip at donders.ru.nl
> http://mailman.science.ru.nl/mailman/listinfo/fieldtrip

More information about the fieldtrip mailing list