[FieldTrip] bug in ft_componentanalysis

Baptiste Gauthier gauthierb.ens at gmail.com
Fri Feb 11 10:46:13 CET 2011

Dear Fieldtrip users,

I noticed a little error in ft_componentanalysis since your latest update
(2011/02/09) :
While using the function, I got this error message :

"??? Error using ==> toc
You must call TIC without an output argument before calling TOC without an
input argument.

Error in ==> ft_componentanalysis at 465
fprintf('total time in componentanalysis %.1f seconds\n', stopwatch(toc));

Error in ==> temprod_NEW_runicaonspectra at 37
    comp                  = ft_componentanalysis(cfg,data);"

It seems there's here a bad use of function toc.m

It should be : "fprintf('total time in componentanalysis %.1f seconds\n',
I tried it and it worked fine.

Please let me know if I'm wrong.


Baptiste gauthier
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.science.ru.nl/pipermail/fieldtrip/attachments/20110211/87187478/attachment-0001.html>

More information about the fieldtrip mailing list