ploting, artifacts, planar saving options, Hilbert, last mail

J.M. Schoffelen Jan.Schoffelen at FCDONDERS.RU.NL
Wed Feb 2 17:55:36 CET 2005

Dear Teresa



Is it possible to use multiplotER for only one dataset of on-going activity?


I would say that it is.

I tried with cfg.yparam = ´datatest´



In general, multiplotER only works with averaged data, i.e. with the output
of freqanalysis, or with the output of timelockanalysis. In addition to
this, when you want to set the yparam, you should use one of the fields
present in the structure you would like to have plotted:




In the case of timelock: cfg.yparam = ‘avg’;

In the case of freq: cfg.yparam = ‘powspctrm’ (AND: cfg.xparam = ‘foi’)



cfgpre = [];


cfgpre.dataset = 'C:\Data\A002-EC_20021016_02.ds'
cfgpre.trl= [1 150000 0]{'MEG' 'HEOG' 'VEOG' 'ECG'}


datatest = preprocessing(cfgpre)


cfgpre.yparam = 'datatest'          
% field to be plotted on y-axis (default = 'avg')


This does not work in the first place, because the thing you want to plot is
a data-structure as outputted by preprocessing, and in the second place
because it does not contain any field named ‘datatest’, nor ‘avg’


Then I tried: 




cfgpre.trl= [[1:2]', [150*ones(1,2)]', [zeros(1,2)]']
avg = timelockanalysis(cfgpre,datatest)
cfgpre.yparam = 'avg'




averaging trial 1 of 1
??? Out of memory. Type HELP MEMORY for your options.


Error in ==> C:\Matlab\FieldTrip\fieldtrip-0.9.4\timelockanalysis.m
On line 402  ==>       dat = data.trial{i}(chansel,begsampl:endsampl);


Do not know if it is just a memory problem - should not be since I choose
small trials (the same to get it as average) - or if it still would not work
with more memory.


Also tried with only 'MEG' channels, but same problem.


Here you define a new trial-definition in cfgpre.trl, but you do not run
your preprocessing again, which does not make too much sense. The out of
memory thing I do not understand either, since if your datatest.trial
consists of ‘only’ one trial with 150000 that should not lead to massive
memory-problems. My first guess would be that something else is going wrong






I read the mail about artifact_eog.m, I am interested in the code that was
not downloaded if that is possible. 


The artifact-routines are available also in the release-version of
fieldtrip. The only thing I reported on this afternoon was that for the
FCDC-users I committed a somewhat cleaned version, with basically the same


And how to use the GUI artifact_viewer.m?




cfgpre.rejecteog = 'yes';


cfgpre.artfctdef.eog.sgn = 'VEOG';
cfgpre.artfctdef.eog.pssbnd = [5 15];
cfgpre.artfctdef.eog.fltord = 4;
cfgpre.artfctdef.eog.padding= 0.2;
cfgpre.artfctdef.eog.pretim = 0.1;
cfgpre.artfctdef.eog.psttim = 0.1;


artifact_viewer (cfgpre, cfgpre.artfctdef, cfgpre.rejecteog, datatest,




??? Undefined function or variable 'artfctchn'.




Also "z_tdata" = data set and what is "flag"?


You cannot use the artifact_viewer like this: it only works in combination
with the ready-made artifact-routines. If you specify cfg.rejecteog = ‘yes’,
and additionally = ‘yes’, the GUI will show up as
soon as you run your preprocessing. Similar things happen with
cfg.rejectmuscle, and cfg.rejectjump. Please read the documentation of the
separate functions, and the information on the fieldtrip-website for
additional information.





Is it possible to save a data set after aplying the megplanar.m in the CTF
".ds" format to open it with the DataEditor?


Not with fieldtrip, and not with other software which I am aware of.






Is it possible to compute the Hilbert transform in order to make a phase
synchronization analysis of the data?


Well, there is a possibility to compute the Hilbert-transform by setting
cfg.hilbert to ‘yes’, prior to doing preprocessing. The only problem is,
that it outputs only the absolute value of the Hilbert transform, so all
phase information is lost. If you would want to do something like that, you
should write your own Hilbert-transformation routine and apply it after
having done preprocessing.



5) /home/common


Is there an external path?






If you are still with me after all these questions, thanks in advance for
your patience.



No problem.






-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the fieldtrip mailing list