[FieldTrip] Topoplots not showing after ICA

Harrison Fisher hfisher at bu.edu
Wed Sep 20 01:02:52 CEST 2023


I am relatively new to field trip, and I’m having an issue with being unable to view topoplots of components after running “runica.” I have data recorded from a 256 Hydrocel EGI net during simultaneous EEG-fMRI. I have preprocessed my data to remove gradient artifact and ballistocardiogram (BCG) artifact. The BCG removal uses a set of the channels that are on a reference layer so that only ~ 40-50 channels are actually on the scalp. 

After all the preprocessing, I have created a new data structure of the cleaned scalp channels, including appropriately subsetting the data.elec structure to retaining channel position information for the scalp channels I keep. I have run ICA with ft_componentanalysis, and I can view the component timeseries with the data browser, but the topoplots are absent. It doesn’t throw any warnings or errors related to the layout. 

I have tried to also generate the layout manually and call ft_topoplotIC for myself to see if I can figure out what is happening. If I generate a layout with the ica output, it returns a layout where the first NComponent entries have positions along the line y=x, and then if I call ft_topoplotIC I get the error "Error using topoplot_common, labels in data and labels in layout do not match”

If I generate a layout from the input data rather than the output component data, I get a valid layout, but then I still get the same exact error with topoplot_common. 

If I generate a layout using only the Ncompontents associated with the runica output, I get a layout that just has a 2x2 array of NaN in the layout.pos, and the same error of labels in data not matching the label. 

Any help or suggestions would greatly be appreciated! 

Harrison Fisher
Phd Candidate in Biomedical Engineering
Boston University

More information about the fieldtrip mailing list