[FieldTrip] scalp is plotted in template sourcemodel & AW: Sourcegrandaverage error due to different "inside" values

Korzeczek, Alexandra alexandra.korzeczek at med.uni-goettingen.de
Thu Feb 20 18:48:46 CET 2020

Dear all,

just to answer my own question: my mistake was not to apply a template grid on individual subjects.
See tutorial step: Performing group analysis on 3-dimensional source-reconstructed data<http://www.fieldtriptoolbox.org/tutorial/sourcemodel/#performing-group-analysis-on-3-dimensional-source-reconstructed-data>.

However, I have a follow-up question:
When I plot the sourcemodel/grid (calculated by a template and the individual mri) not the brain as shown in the tutorial but the scalp is plotted. The "scalp -sourcemodel" plot remains, even when using the example mri. Should I use the segmented mri as input to ft_prepare_sourcemodel instead?

%% compute the source model
cfg = [];
cfg.warpmni   = 'yes';
cfg.template  = template.sourcemodel;
cfg.nonlinear = 'yes'; % use non-linear normalization
cfg.mri            = mri; ## HERE Use segementedmri?

sourcemodel        = ft_prepare_sourcemodel(cfg);

Thanks and Best,

Von: fieldtrip <fieldtrip-bounces at science.ru.nl> Im Auftrag von Korzeczek, Alexandra
Gesendet: Mittwoch, 19. Februar 2020 18:14
An: FieldTrip discussion list <fieldtrip at science.ru.nl>
Betreff: [FieldTrip] Sourcegrandaverage error due to different "inside" values

Dear Fieldtrip community,

has anyone a suggestion what might be my mistake for not being able to run ft_sourcegrandaverage over several subjects?
I am using FT version (20180906) applying beamformer on each individual subject prior to normalize individual subjects to MNI space.
I receive the error message: Error using ft_sourcegrandaverage (line 116), the input sources vary in the field.
This error is due to different values of my "src.inside" field. Some years ago (https://mailman.science.ru.nl/pipermail/fieldtrip/2015-October/009709.html)
the same error was solved by adding the pos of a template. However, this does not work with my data.
Am I using a wrong template maybe? My original dimensions after using sourceinterpolate are [160,160,128].

The datainput to sourcegrandaverage (and output of ft_volumenormalise) looks like that:
src_mni.anatomy   [181x217x181] double
src_mni.pow           [181x217x181] double
src_mni.inside        [181x217x181] logical
src_mni.transform 4x4 double
src_mni.dim           [181,217,181]
src_mni.params     1x1 struct
src_mni.initial        4x4 double
src_mni.coordsys  'spm'
src_mni.cfg            1x1 struct

My script is:
% source interpolate
cfg  = [];
cfg.parameter = 'pow';
src_interp  = ft_sourceinterpolate(cfg, src , realmri);

% normalize to MNI
cfg  = [];
cfg.nonlinear = 'no';
src_mni  = ft_volumennormalise(cfg, src_interp);


Alexandra Korzeczek
PhD Student | BeCog Geog-August-Universität Göttingen
University Medicine Göttingen | Dept. of Clinical Neurophysiology

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.science.ru.nl/pipermail/fieldtrip/attachments/20200220/f6342747/attachment.htm>

More information about the fieldtrip mailing list