[FieldTrip] Subject: Dysfunction with ft_definetrial

Tony TREE tonychshug at 126.com
Tue Jul 2 14:38:33 CEST 2019

Dear Fieldtrip Community,

I'm focusing on the research of brain computer interface on stroke rehabilitation. Currently I tried ft_definetrial but I received the following error message:
Error using fopen_or_error (line 24)
could not open file .
Error in load_curry_data_file (line 54)
fid = fopen_or_error(ParameterFile,'rt');
Error in ft_read_header (line 744)
    orig            = load_curry_data_file(filename);
Error in ft_trialfun_general (line 84)
  hdr = ft_read_header(cfg.headerfile, 'headerformat', cfg.headerformat);
Error in ft_definetrial (line 185)
    [trl, event] = feval(cfg.trialfun, cfg);

The cfg (run ft definetrial) and data (LM_1) I used are in the link: https://www.dropbox.com/sh/zggeusihhbeoeg0/AACWpO6MgiLr_lOTZRCzBm2ba?dl=0.

The versions I used are: Matlab R2013b, eeglab14_1_2b and fieldtrip-20190618. I have also tried Matlab 2019, eeglab13_5_4b, fieldtrip-20190606, fieldtrip-20131231 as well as fieldtrip-20121231. But they didn't work and came out with the same error.

Besides, I also run:
addpath E:\fieldtrip-20190618
but it still didn't work.

Now I have no idea of what is the problem. Waiting for your kind reply. Thank you all.

Tony Chen
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.science.ru.nl/pipermail/fieldtrip/attachments/20190702/7ea2c7d5/attachment-0001.html>
-------------- next part --------------
fieldtrip mailing list

More information about the fieldtrip mailing list