[FieldTrip] Can I rename the CTF HLC0011 etc... to {'nasX'; 'nasY'; 'nasZ'; 'lpaX'; 'lpaY'; 'lpaZ'; 'rpaX'; 'rpaY'; 'rpaZ'}?

Anne Urai anne.urai at gmail.com
Tue May 24 11:56:55 CEST 2016


Dear FieldTrippers,

I'm using ft_megrealign after timelocking my data for each participant and
recording, and before appending these different recording sessions (and
subsequently taking grand averages over subjects). Since the experiment
consisted of different sessions a few weeks apart, I'd like to minimise
noise due to differences in head position (we used online head
localisation, but this did not work very well for all participants when
coming back a few weeks later.

After making the headmodel (and ensuring it's aligned with the
gradiometers), this works quite well:

% realign to template sensor positions

cfg             = [];

cfg.template    = {'ctf275.mat'};

cfg.headmodel   = headmodel;



% For a realistic single-shell volume conduction model based on the brain
surface, you

% should probably use an inward shift of about 1 cm.

cfg.inwardshift  = 1;

cfg.feedback     = 'no';

data2            = ft_megrealign(cfg, data);

However, when looking into the ft_megrealign function I found that there is
the option of doing this per trial based on the CTF coil positions (rather
than once based on the gradiometer definition at the beginning of the run).
This seems sensible for participants who moved quite a bit during a
recording. However, CTF does not originally output
the {'nasX';'nasY';'nasZ';'lpaX';'lpaY';'lpaZ';'rpaX';'rpaY';'rpaZ'} that
the function looks for.

In ft_headmovement (and also buried somewhere in the CTF documentation), I
could find
% HLC0011 HLC0012 HLC0013 x, y, z coordinates of nasion-coil in m.
% HLC0021 HLC0022 HLC0023 x, y, z coordinates of lpa-coil in m.
% HLC0031 HLC0032 HLC0033 x, y, z coordinates of rpa-coil in m.

So it seems reasonable to simply rename these to the channel names that
ft_megrealign is looking for. When doing this, realignment indeed happens
at the single trial level. However, I wanted to check if there is a reason
for using the nasX nasY... channel names rather than the original HLC0011..
ones? Can I rename them while keeping the rest of the HLC channels (of
which there are 24) the same? I can't think of a reason why this would
cause any issues, but since I could not find the 'per-trial' option
documented I thought I'd check what the rationale behind using per-trial or
per-run is.

Thanks!
Cheers,

—
Anne E. Urai, MSc
PhD student | Institut für Neurophysiologie und Pathophysiologie
Universitätsklinikum Hamburg-Eppendorf | Martinistrasse 52, 20246 |
Hamburg, Germany
www.anneurai.net / @AnneEUrai <https://twitter.com/AnneEUrai>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.science.ru.nl/pipermail/fieldtrip/attachments/20160524/57b1a81b/attachment-0001.html>


More information about the fieldtrip mailing list