[FieldTrip] loreta2fieldtrip function error

Ingrid Nieuwenhuis inieuwenhuis at berkeley.edu
Thu May 30 19:30:41 CEST 2013

Hi Fatemeh,

I had the same error recently when I did the same. I filed the bug, see 

I did create a work around. In the LORETA program, you can export the 
source data as a text file. You can read that text file in with 
loreta2fieldtrip.m. It's a bit of a patch, but it worked for me.

Hope this helps,

On 5/30/2013 10:14 AM, Fatemeh Ebrahimi nia wrote:
> Hi dear all,
> I am analyzing EEG data. I have computed sLORETA (.slor) from ERP 
> data. Now I want to read and convert LORETA source reconstruction into a
> MATLAB data structure using "loreta2fieldtrip" function, But I have 
> gotten the bellow error.
> **** Error using fread
> Invalid precision.
> Error in loreta2fieldtrip (line 85)
> activity = fread(fid, [voxnumber Ntime], 'float = >single'); ***
> Can someone give me a help?
> Best regards,
> Fatemeh
> _______________________________________________
> fieldtrip mailing list
> fieldtrip at donders.ru.nl
> http://mailman.science.ru.nl/mailman/listinfo/fieldtrip

Ingrid Nieuwenhuis PhD
Postdoctoral Fellow
Sleep and Neuroimaging Laboratory
Department of Psychology
University of California, Berkeley
California 94720-1650
Tolman Hall, room 5305

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.science.ru.nl/pipermail/fieldtrip/attachments/20130530/935429cf/attachment-0002.html>

More information about the fieldtrip mailing list