[FieldTrip] Error in ft_rejectartifact for the newest fieldtrip version

Izabela Mikula Izabela.Mikula at mpi.nl
Tue Aug 6 12:10:32 CEST 2013

Dear all,
I was wondering if any of you have ever encountered similar problem and might know if I'm doing something wrong or it is a bug..

I have tried using (my old scripts for preprocessing) ft_rejectartifact(cfg, data) but I get an error:

evaluating artifact_jump
??? Error using ==> feval
Undefined function or method 'artifact_jump' for input arguments of type 'struct'.

Error in ==> ft_rejectartifact at 257
    cfg = feval(sprintf('artifact_%s', cfg.artfctdef.type{type}), cfg, data);

It is important to note that this error only occurs when using the newest fieldtrip version. For previous versions it works without any problems. I have also tried multiple datasets, but the problem remains.
data = 

       fsample: 1200
          grad: [1x1 struct]
    sampleinfo: [180x2 double]
     trialinfo: [180x1 double]
         trial: {1x180 cell}
          time: {1x180 cell}
         label: {273x1 cell}
           cfg: [1x1 struct]


cfg.artfctdef = 

          reject: 'complete'
            jump: [1x1 struct]
          muscle: [1x1 struct]
            type: {2x1 cell}
    minaccepttim: 0.1000
      crittoilim: []
        feedback: 'no'

Thanks in advance!


More information about the fieldtrip mailing list