[FieldTrip] ft_sourcestatistics

Stenner, Max-Philipp max-philipp.stenner at med.ovgu.de
Thu Mar 8 14:36:16 CET 2012

Hi Jan-Mathijs,

thank you for your response, since it worked for cfg.implementation = 'old' I haven't tried your suggestion of calling ft_checkdata outside of ft_sourcestatistics so far but will later during the day,

thanks again,



Von: fieldtrip-bounces at donders.ru.nl [fieldtrip-bounces at donders.ru.nl]" im Auftrag von "jan-mathijs schoffelen [jan.schoffelen at donders.ru.nl]
Gesendet: Donnerstag, 8. März 2012 13:38
Bis: Email discussion list for the FieldTrip project
Betreff: Re: [FieldTrip] ft_sourcestatistics

Hi Max,

At the moment we are designing some major code changes to deal with source level data, and we need to ask you for some patience in this regard.
For now, you could try to move the call to ft_checkdata to outside ft_sourcestatistics, and change the powdimord into 'pos_rpt';
Does it work if you subsequently call ft_sourcestatistics (with cfg.implementation = 'new')? This new implementation has never fully matured and may be instable. It has been found to work in certain situations, but it has never been fully tested on all possible processing histories that users may throw at it. Hence the urgent need to clean up the code.



On Mar 7, 2012, at 6:46 PM, Stenner, Max-Philipp wrote:

Dear fieldtrip users,

I am encountering a problem with ft_sourcestatistics when using output from ft_sourcegrandaverage. My parameter of interest is a logratio: log(mean(moments(time of interest))/mean(moments(baseline))) which I simply named 'pow' to be compatible with ft functions. Apart from this, nothing else deviates from how fieldtrip handles the data/nothing else was changed 'manually'.

The problem arises from the fact that the existence of 10 different subjects in the grandaverage (in the usual 1x10 struct field 'trial') isn't represented in the 'powdimord' field of the data after ft_checkdata(varargin{i}, 'datatype', {'source', 'volume'}, 'feedback', 'no', 'inside', 'index', 'sourcerepresentation', 'new'); in the new implementation of ft_sourcestatistics:


ans =

(before ft_checkdata:)

       pos: [8196x3 double]
       var: [1x1 struct]
    dimord: 'voxel'
     trial: [1x10 struct]
    inside: [8196x1 double]
   outside: [0x1 double]
        df: [8196x1 double]
       cfg: [1x1 struct]

(after ft_checkdata:)

         pos: [8196x3 double]
         var: [1x1 struct]
      dimord: 'pos'
      inside: [8196x1 double]
     outside: [0x1 double]
          df: [8196x1 double]
         cfg: [1x1 struct]
         pow: [8196x10 double]
   powdimord: 'pos'

This leads to a (wrong) transpose of the design (originally row1 = uvar, row2 = ivar [with two conditions for a depsamples T test]) and ultimately to the message

'The data must contain at least two units (usually subjects).'

Any help would be much appreciated, thanks very much!


(fieldtrip version: fieldtrip-lite-20111130 on a Windows7 PC)
fieldtrip mailing list
fieldtrip at donders.ru.nl<mailto:fieldtrip at donders.ru.nl>

Jan-Mathijs Schoffelen, MD PhD

Donders Institute for Brain, Cognition and Behaviour,
Centre for Cognitive Neuroimaging,
Radboud University Nijmegen, The Netherlands

Max Planck Institute for Psycholinguistics,
Nijmegen, The Netherlands

J.Schoffelen at donders.ru.nl<mailto:J.Schoffelen at donders.ru.nl>
Telephone: +31-24-3614793

More information about the fieldtrip mailing list