[FieldTrip] volume conduction model missing .mat

Akiko Ikkai akiko.ikkai at gmail.com
Wed Feb 15 17:45:37 CET 2012


Dear Fieldtrip users,

Thank you Patrick, Nathan & Gio for your inputs. My MRI anatomical images
need extensive cleaning (enhance contrasts, get rid of non-zero voxels
outside the brain, etc...) before segmentation, as well as adjusting
cfg.threshold for each tissue type during segmentation and each subject. At
least testing with SPM standard MRI, segmentation and forward modeling
works OK now.

Individual subject's MRI, though, is still problematic, and I have a
question for Fieldtrip developers: could you let me know whether "Create
BEM headmodel for EEG (
http://fieldtrip.fcdonders.nl/example/create_bem_headmodel_for_eeg )"
routine is what you recommend, or it's integrated into a newer function
with newer cfg options? Is there a page I missed on the web?

Thank you so much for your time!
Akiko

On Fri, Feb 10, 2012 at 4:36 AM, Gio Piantoni <g.piantoni at nin.knaw.nl>wrote:

> Hi Akiki and Patrick,
>
> I agree with Nathan about segmentation problems. I had the same
> problem when two of the three meshes intersected each other. Before
> you run the forward model, you should check the segmentation (bnd)
> using ft_plot_mesh.
> ft_plot_mesh(bnd(1), 'facealpha', .5)
> hold on
> ft_plot_mesh(bnd(2), 'facecolor', 'r')
> You will see that the two meshes intersect with each other. Depending
> on how you created the meshes, you should fix the parameters in such a
> way that they don't intersect. For example, ft_volumesegment has a
> cfg.threshold option (you can check how the segmentation went with
> ft_sourceplot) and ft_prepare_mesh_new has cfg.thresholdseg and
> cfg.smoothseg.
>
> I think that the meshes in SPM are computed on an (affine-transformed)
> template and not on the anatomically derived meshes. The template is
> more robust and that's why the two surfaces do not intersect.
>
> In general, the segmentation depends on the quality of your MRIs and
> you should really visually check the segmentation and meshes. When
> those look ok, the BEM forward model usually works. Hope this helps.
>
> Cheers,
>
> Gio
>
> On Fri, Feb 10, 2012 at 09:00, Nathan Weisz <nathanweisz at mac.com> wrote:
> > Hi Akiki,
> >
> > I am not a headmodel expert.
> > but looking at the output message, it seems your segementation did not go
> > too well (see the "intersect" message). my intuition is then then the
> next
> > temporary file *.ama is not created and ft_prepare_bemmodel then simply
> says
> > ciao.
> >
> > perhaps you want to check / redo the segmentation?
> >
> > good luck,
> > nathan
> >
> >
> > On 09.02.2012, at 23:04, Akiko Ikkai wrote:
> >
> > Hi,
> >
> > I'm trying to create a volume conduction model for my EEG study based on
> > anatomical MRI, and having trouble with ft_prepare_bemmodel
> >
> > when I run
> > cfg                = [];
> > cfg.tissue         = [7 4 1]; % value for brain, skull, and scalp
> > cfg.conductivity   = [1 1/80 1]*.33; % after standard_BEM.zip data
> > cfg.isolatedsource = true;
> > cfg.method         = 'dipoli';
> > cfg.sourceunits = 'mm';
> > cfg.mriunits = 'mm';
> > vol = ft_prepare_bemmodel(cfg, seg4bem);
> >
> > I get the following error message while ft_prepare_bemmodel is running:
> >
> > Fatal error in dipoli:  interface
> > /private/tmp/tpd8a04422_e19e_4978_9b9b_56d1f2696492.tri and
> > /private/tmp/tp313c9a32_1991_4df6_a404_8efc41b6302e.tri intersect
> >  at vertex 1402 of
> /private/tmp/tpd8a04422_e19e_4978_9b9b_56d1f2696492.tri
> >
> > Warning: an error ocurred while running dipoli
> >> In dipoli at 94
> >   In ft_prepare_bemmodel at 112
> > Error using ==> fread
> > Invalid file identifier.  Use fopen to generate a valid file identifier.
> > Warning: File '/private/tmp/tp0c0779e3_a657_4ca5_b9e1_845f41e9574a.ama'
> not
> > found.
> >> In dipoli at 102
> >   In ft_prepare_bemmodel at 112
> >
> >
> > and the output vol is missing .mat, which causes an error
> > during ft_sourceanalysis.
> >>> vol
> > vol =
> >             cond: [0.3300 0.0041 0.3300]
> >              bnd: [1x3 struct]
> >           source: 3
> >     skin_surface: 3
> >             skin: 1
> >             type: 'dipoli'
> >
> > Does anyone know how to correct for "fatal error" so
> > that ft_prepare_bemmodel creates the correct volume conduction model? I
> > opened .tri file and removed line 1402, but got the same results.
> >
> > Thanks in advance! Akiko
> >
> > --
> > Akiko Ikkai, Ph.D.
> > Postdoctoral Fellow
> > Department of Psychological and Brain Sciences
> > Johns Hopkins University
> > Ames Hall, 3400 N. Charles St.
> > Baltimore, MD 21218
> >
> >
> > _______________________________________________
> > fieldtrip mailing list
> > fieldtrip at donders.ru.nl
> > http://mailman.science.ru.nl/mailman/listinfo/fieldtrip
> >
> >
> >
> > _______________________________________________
> > fieldtrip mailing list
> > fieldtrip at donders.ru.nl
> > http://mailman.science.ru.nl/mailman/listinfo/fieldtrip
>
> _______________________________________________
> fieldtrip mailing list
> fieldtrip at donders.ru.nl
> http://mailman.science.ru.nl/mailman/listinfo/fieldtrip
>



-- 
Akiko Ikkai, Ph.D.
Postdoctoral Fellow
Department of Psychological and Brain Sciences
Johns Hopkins University
Ames Hall, 3400 N. Charles St.
Baltimore, MD 21218
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.science.ru.nl/pipermail/fieldtrip/attachments/20120215/622bf2dc/attachment-0001.html>


More information about the fieldtrip mailing list