[FieldTrip] ft_qualitycheck

Andreas Sauer sauer.mpih at googlemail.com
Mon Aug 13 11:39:23 CEST 2012


Dear Arjen,

thanks for your replay!

I just tried with the current version of fieldtrip (20120812) but I still
get this error message:


??? Undefined function or variable 'dataset'.

Error in ==> boxplot>computeBoxLocation at 2020
boxValDs = dataset();

Error in ==> boxplot at 312
[boxVal,boxValPlot,boxIdx] = computeBoxLocation(xSorted,...

Error in ==> ft_qualitycheck>draw_figure at 547
  boxplot(h.HmotionAxes, hmotions, 'orientation', 'horizontal', 'notch',
'on');

Error in ==> ft_qualitycheck at 296
      draw_figure(info, temp_timelock, temp_freq, temp_summary,
temp_headpos, toi);


I call the function ft_qualitycheck as described in the tutorial.
cfg.dataset = subject_xy.ds; ft_qualitycheck(cfg). It runs the analysis, it
writes the .mat-file but then it throws the error message. So to me, it
seems that there is some information (the variable 'dataset') missing. But
I don't know whether this is due to our recording or an error in one of the
functions...

Best,

Andreas




2012/8/10 Stolk, A. <a.stolk at fcdonders.ru.nl>

> Hi Andreas,
>
>
>
> The boxplot function is a matlab statistics toolbox function. I do not see
> why it throws an error here. However, I did find a problem related to the
> dataset history file (.hist) which contains details of the recording
> itself. I will fix this issue right away. If you are still getting the same
> error with tomorrow's version of FT, please give me shout. And
> preferably provide some more details about the error, and how you are
> calling the function.
>
>
>
> best,
>
> Arjen
>
>
>
>
> ------------------------------
>
> *Van: *"Andreas Sauer" <sauer.mpih at googlemail.com>
> *Aan: *fieldtrip at science.ru.nl
> *Verzonden: *Vrijdag 10 augustus 2012 15:49:47
> *Onderwerp: *[FieldTrip] ft_qualitycheck
>
>
> Dear all,
>
> I tried to check my MEG (CTF) datasets with ft_qualitycheck. Unfortunately
> it didn't work. An error occurs in the boxplot.m function in line 2020,
> where the data should be copied into the dataset. But for me, there is no
> dataset().
>
> My question is whether this is due to my dataset-information or due to an
> error in the script? An how to solve this issue?
>
> Any help is highly appreciated!
>
> Thanks!
>
> Best regards,
>
> Andreas
>
>
> --
>  Andreas Sauer
> Max Planck Institute for Brain Research
> Department of Neurophysiology
> Deutschordenstra├če 46
> 60528 Frankfurt am Main
> Germany
>
> T: +49 69 96769 278
> F: +49 69 96769 327
> Email: sauer.mpih at gmail.com
> www.brain.mpg.de
>
>
> _______________________________________________
> fieldtrip mailing list
> fieldtrip at donders.ru.nl
> http://mailman.science.ru.nl/mailman/listinfo/fieldtrip
>
>
>
> _______________________________________________
> fieldtrip mailing list
> fieldtrip at donders.ru.nl
> http://mailman.science.ru.nl/mailman/listinfo/fieldtrip
>



-- 
Dipl.-Psych. Andreas Sauer
Max Planck Institute for Brain Research
Deutschordenstra├če 46
60528 Frankfurt am Main
Germany

T: +49 69 96769 278
F: +49 69 96769 327
Email: sauer.mpih at gmail.com
www.brain.mpg.de
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.science.ru.nl/pipermail/fieldtrip/attachments/20120813/e9f52243/attachment-0002.html>


More information about the fieldtrip mailing list