[FieldTrip] error using spm_slice_vol

jan-mathijs schoffelen jan.schoffelen at donders.ru.nl
Wed May 11 10:59:06 CEST 2011

Hi Allison,

This looks like an SPM-related error to me, or it is operating system  
related. Can you check which spm-version you are using, in other  
words: is it the fieldtrip/external/spmXXX directory, or do you have  
spm somewhere else on your matlab-path? If it is the former, then it  
is a potential bug which needs fixing by us. Otherwise we cannot help  
What kind of operating system are you using?



On May 4, 2011, at 3:56 PM, Allison Connolly wrote:

> Hi all,
> I am trying to segment an mri volume using. When I call  
> ft_read_mri('filename'), I get an error that says:
> ??? Error using ==> spm_slice_vol at 28
> spm_slice_vol.c not compiled - see spm_MAKE.sh
> Error in ==> spm_read_vols at 35
>     Y(:,:,p,i) = spm_slice_vol(V(i),spm_matrix([0 0  
> p]),V(i).dim(1:2),0);
> Error in ==> ft_read_mri at 97
>   img = spm_read_vols(hdr);
> I tried installing the most up to date version of fieldtrip and I  
> still get the same error. Can someone help me?
> -Allison
> _______________________________________________
> fieldtrip mailing list
> fieldtrip at donders.ru.nl
> http://mailman.science.ru.nl/mailman/listinfo/fieldtrip

Dr. J.M. (Jan-Mathijs) Schoffelen
Donders Institute for Brain, Cognition and Behaviour,
Centre for Cognitive Neuroimaging,
Radboud University Nijmegen, The Netherlands
J.Schoffelen at donders.ru.nl
Telephone: 0031-24-3614793

More information about the fieldtrip mailing list