problems using fieldtrip

Robert Oostenveld r.oostenveld at FCDONDERS.RU.NL
Tue Aug 9 15:38:55 CEST 2005

Dear Hoi Fei

On 9-aug-2005, at 15:05, Hoi Fei Kwok wrote:
> This is the first time that I am using FieldTrip. Just like to ask
> what
> other software are needed besides MATLAB in order to run the
> tutorials. I

Some parts of the tutorials use CTF specific applications. That is
commercial software only available to CTF MEG users. However, you can
skip those parts of the tutorial. Furthermore, I think that there is
a tutorial that refers to MRIcro, you can get that here: http://

> have tried to run the tutorials after downloading and unzipping the
> but I ran into problems.
> Firstly, in the Event Related Averaging tutorial, the
> EventRelatedAveraging.m was mentioned but I could not find the file.

you can copy and paste all matlab instructions from the pdf into the
matlab command line window. I will also make the demo scripts
available for download on the website, but I won't be able to do that

> Secondly, after I created a cfg structure with 'Subject01.ds' as the
> dataset and all the other field properties as instructed in the
> tutorial, I
> got the following error message when using the preprocessing.m:
> CTF_READ_RES4 [v  1.12]
> ??? Error using ==> read_fcdc_header
> could not read CTF res4 header file
> Error in ==> preprocessing at 219
> hdr = read_fcdc_header(cfg.headerfile);

Are you at the right location with Matlab? I.e., if you type "pwd",
does that correspond with the directory where Subject01.ds is located?

best regards,

More information about the fieldtrip mailing list